Accueil > Windows Azure > Modification de la configuration par défaut des WebRole Azure ????

Modification de la configuration par défaut des WebRole Azure ????

Bizarrement une de mes applications ASP.NET qui fonctionnait parfaitement dans Azure, vient récemment de me poser des soucis. Plus particulièrement les services WCF qu’elle contient (.svc) alors qu’aucune modification ni redéploiement n’avait eu lieu.

Après une courte investigation il apparait qu’une modification de configuration par défaut des webrole a du avoir lieu sur Azure ( où est le mail ou le message d’avertissement ???). Le runtime ASP.NET d’azure refusait ainsi de lancer mes services car il n’indiquaient pas qu’ils supportaient le mode de compatibilité ASP.Net.

Pour allez au plus simple, j’ai simplement ajouté l’attribut [AspNetCompatibilityRequirements(RequirementsMode=AspNetCompatibilityRequirementsMode.Allowed)] sur mes classes de service, redéployé l’application et tout est rentré dans l’ordre.

Catégories :Windows Azure
  1. Aucun commentaire pour l’instant.
  1. No trackbacks yet.

Laisser un commentaire

Entrez vos coordonnées ci-dessous ou cliquez sur une icône pour vous connecter:

Logo WordPress.com

Vous commentez à l'aide de votre compte WordPress.com. Déconnexion / Changer )

Image Twitter

Vous commentez à l'aide de votre compte Twitter. Déconnexion / Changer )

Photo Facebook

Vous commentez à l'aide de votre compte Facebook. Déconnexion / Changer )

Photo Google+

Vous commentez à l'aide de votre compte Google+. Déconnexion / Changer )

Connexion à %s

%d blogueurs aiment cette page :